What do I do if a video is not loading?
If a video is slow to load or if you or a student are experiencing an error message when trying to view a video, there may be an issue with network bandwidth or video permissions or preference. The video and article below offer solutions to the following 4 video issues:
- Video is slow to load
- "400 Bad Request" error message
- Video is no longer available
- Video is restricted
(Watch the video or read the article below to help troubleshoot video issues.)
Issue #1: Video is slow to load
-
Indicator(s):
-
The video is slow to load or has stopped buffering or you see a circle indicating that the content is still loading.
-
Cause(s):
-
This is most likely caused by low network bandwidth.
-
Solution(s):
-
At home:
- Decrease your use of bandwidth on other devices by asking others in your household to temporarily cease watching video.
- Restart your internet modem and/or router.
- Restart your computer.
In the classroom:
- Switch your class to one-to-many mode. This allows you to project video for students, which means only one device in the classroom is using up video bandwidth. Students will see a message on their screen that they're watching the video in class.
- If you or your students will be consistently working on a low-bandwidth network, contact us at checkologyhelp@newslit.org for low-bandwidth resources to learn with Checkology.
Issue #2: "400 Bad Request" error message
-
Indicator(s):
-
The screen is white and it says "400 Bad Request."
-
Cause(s):
-
It is likely that stored browser data is preventing Checkology content from loading correctly.
-
Solution(s):
-
- Clear your browser's cache
- Use your browser's incognito mode.
Issue #3: Video unavailable
-
Indicator(s):
-
You see an error message that says "Video unavailable" or "This video is no longer available" or something similar.
-
Cause(s):
-
This message indicates that the video was removed from one of Checkology's three streaming services (Youtube, Vimeo, or Wistia).
-
Solution(s):
-
- Switch your video preference.
- Report the removed video to NLP. Please send the name of the lesson, the lesson element number (found on the bottom right), and the name of the streaming service on which you got the error to checkologyhelp@newslit.org.
Issue #4: Video is restricted
-
Indicator(s):
-
You see an error message that says "This video is restricted" or something similar.
- Cause(s):
-
This message occurs when your video preference is set to YouTube and students are using Chromebooks linked to their restricted Google accounts.
- Solution(s):
-
- Switch your video preference to either Wistia or Vimeo.